Changes from 1.0.x to 1.1.x

AstLinux 1.1.x is a medium upgrade from the previous 1.0.x series. Most notable are:

  • Prosody XMPP/Jabber server
  • Asterisk Calendar integration
  • Perl - more complete support
  • Lua - added scripting language
  • Minor Linux Kernel upgrade
  • Many Package updates

Board changes in AstLinux 1.1.x

  • “via[-serial]” and “viac7[-serial]” board types will be automatically redirected to “geni586[-serial]” board types. Since the release of AstLinux 1.x using a unified kernel config across all boards, the usefulness of special “via” and “viac7” board types has been eliminated. Users do not have to do anything special, upgrading with “upgrade-run-image” or the web interface System tab is all that is required.
  • “net4801” and “wrap” board types have reached end-of-life. AstLinux 1.0.6 was the last supported version.
  • Current supported board types are: “geni586”, “geni586-serial”, “alix” and “net5501”

Asterisk changes in AstLinux 1.1.x

  • AstLinux images now will be provided with Asterisk 1.8.x and Asterisk 11.x.
  • Asterisk 1.4.x users are urged to upgrade their configurations to Asterisk 1.8.x or Asterisk 11.x, primarily for obtaining the latest security updates.

Changes from 1.0.x to 1.1.x

  • When you upgrade be sure to read the complete 1.1.0 ChangeLog.txt
  • Minor Linux kernel bump (2.6.35.14 in 1.1.0 compared to 2.6.35.13 in 1.0.6)
  • Prosody, an XMPP Server supporting Messaging and Presence has been added. New XMPP_* rc.conf variables and web interface configuration support.
    It is supported as a sub-tab from the Network tab: Network tab → Network Services: XMPP Server, Messaging and Presence { Configure XMPP }
  • Asterisk Calendar Support: CalDAV, iCalendar(.ics), MS Exchange and MS Exchange Web Service
  • Lua, a simple, efficient programming language is now supported, version 5.1.5.
    Additional Lua Modules: luafilesystem, luasocket, luaexpat, luasec
    More Info: http://www.lua.org/
  • perl, version bump to 5.16.2. No longer use “microperl”, now using “miniperl” which is a cross-compiled version of full perl using perlcross. While compiled modules are now supported, only a limited set of perl modules are included because of our small image size design.
    Note: The directory “/mnt/kd/perl” will be searched for additional perl modules, such as Asterisk::AGI.
    Issue 'perl -V' from the CLI for more details including the –only-mod= modules.
    Issue 'find /usr/lib/perl -name “*.pm”' to show all installed perl modules.
    • Asterisk AGI scripts using “perl” are better supported, for example Asterisk::AGI is supported if the “/mnt/kd/perl” directory contains Asterisk.pm and Asterisk/AGI.pm
      More Info: http://search.cpan.org/~jamesgol/asterisk-perl-1.03/lib/Asterisk/AGI.pm
    • Note: The DAHDI commands 'dahdi_genconf' and 'dahdi_hardware' now work with the new installed perl.
  • OpenVPN Server sub-tab, added a new “Private Key Size:” entry, 1024 or 2048 Bits. Future generated keys/certificates will use the private key size value.
  • Many, many updates.